import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "BuildingEnvelope.* |Heating.* |Ventilation.* |Occupancy.* |weatherdata.*\"|aziShift=.*\\)";
final String string = " redeclare AllHouses.Submodels.Ventilation.Ventilation ventilation,\n"
+ " gridTable=ModelicaServices.ExternalReferences.loadResource(\"modelica://AllHouses/Resources/grids/tables.txt\"),\n"
+ " weatherFile=ModelicaServices.ExternalReferences.loadResource(\"modelica://AllHouses/Resources/weatherdata/Uccle.TMY\"),\n"
+ " redeclare AllHouses.Submodels.BuildingEnvelope.VLA2 buildingEnvelope,\n"
+ " redeclare AllHouses.Submodels.Heating.FloorHeating heating,\n"
+ " redeclare AllHouses.Submodels.Occupancy.Occupancy occupancy,\n"
+ " sim(aziShift=0));";
final String subst = "AAAAAAAAAAAAAAAAAAAAAA";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}