# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r'BuildingEnvelope.* |Heating.* |Ventilation.* |Occupancy.* |weatherdata.*"|aziShift=.*\)'
test_str = (" redeclare AllHouses.Submodels.Ventilation.Ventilation ventilation,\n"
" gridTable=ModelicaServices.ExternalReferences.loadResource(\"modelica://AllHouses/Resources/grids/tables.txt\"),\n"
" weatherFile=ModelicaServices.ExternalReferences.loadResource(\"modelica://AllHouses/Resources/weatherdata/Uccle.TMY\"),\n"
" redeclare AllHouses.Submodels.BuildingEnvelope.VLA2 buildingEnvelope,\n"
" redeclare AllHouses.Submodels.Heating.FloorHeating heating,\n"
" redeclare AllHouses.Submodels.Occupancy.Occupancy occupancy,\n"
" sim(aziShift=0));")
subst = "AAAAAAAAAAAAAAAAAAAAAA"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur'' to prefix the regex and u"" to prefix the test string and substitution.