using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"BuildingEnvelope.* |Heating.* |Ventilation.* |Occupancy.* |weatherdata.*""|aziShift=.*\)";
string substitution = @"AAAAAAAAAAAAAAAAAAAAAA";
string input = @" redeclare AllHouses.Submodels.Ventilation.Ventilation ventilation,
gridTable=ModelicaServices.ExternalReferences.loadResource(""modelica://AllHouses/Resources/grids/tables.txt""),
weatherFile=ModelicaServices.ExternalReferences.loadResource(""modelica://AllHouses/Resources/weatherdata/Uccle.TMY""),
redeclare AllHouses.Submodels.BuildingEnvelope.VLA2 buildingEnvelope,
redeclare AllHouses.Submodels.Heating.FloorHeating heating,
redeclare AllHouses.Submodels.Occupancy.Occupancy occupancy,
sim(aziShift=0));";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}