import Foundation
let pattern = #"BuildingEnvelope.* |Heating.* |Ventilation.* |Occupancy.* |weatherdata.*"|aziShift=.*\)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
redeclare AllHouses.Submodels.Ventilation.Ventilation ventilation,
gridTable=ModelicaServices.ExternalReferences.loadResource("modelica://AllHouses/Resources/grids/tables.txt"),
weatherFile=ModelicaServices.ExternalReferences.loadResource("modelica://AllHouses/Resources/weatherdata/Uccle.TMY"),
redeclare AllHouses.Submodels.BuildingEnvelope.VLA2 buildingEnvelope,
redeclare AllHouses.Submodels.Heating.FloorHeating heating,
redeclare AllHouses.Submodels.Occupancy.Occupancy occupancy,
sim(aziShift=0));
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"AAAAAAAAAAAAAAAAAAAAAA"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)