const regex = new RegExp('BuildingEnvelope.* |Heating.* |Ventilation.* |Occupancy.* |weatherdata.*"|aziShift=.*\\)', 'gm')
const str = ` redeclare AllHouses.Submodels.Ventilation.Ventilation ventilation,
gridTable=ModelicaServices.ExternalReferences.loadResource("modelica://AllHouses/Resources/grids/tables.txt"),
weatherFile=ModelicaServices.ExternalReferences.loadResource("modelica://AllHouses/Resources/weatherdata/Uccle.TMY"),
redeclare AllHouses.Submodels.BuildingEnvelope.VLA2 buildingEnvelope,
redeclare AllHouses.Submodels.Heating.FloorHeating heating,
redeclare AllHouses.Submodels.Occupancy.Occupancy occupancy,
sim(aziShift=0));`;
const subst = `AAAAAAAAAAAAAAAAAAAAAA`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);