package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)BuildingEnvelope.* |Heating.* |Ventilation.* |Occupancy.* |weatherdata.*"|aziShift=.*\)`)
var str = ` redeclare AllHouses.Submodels.Ventilation.Ventilation ventilation,
gridTable=ModelicaServices.ExternalReferences.loadResource("modelica://AllHouses/Resources/grids/tables.txt"),
weatherFile=ModelicaServices.ExternalReferences.loadResource("modelica://AllHouses/Resources/weatherdata/Uccle.TMY"),
redeclare AllHouses.Submodels.BuildingEnvelope.VLA2 buildingEnvelope,
redeclare AllHouses.Submodels.Heating.FloorHeating heating,
redeclare AllHouses.Submodels.Occupancy.Occupancy occupancy,
sim(aziShift=0));`
var substitution = "AAAAAAAAAAAAAAAAAAAAAA"
fmt.Println(re.ReplaceAllString(str, substitution))
}