# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([\wá-ú])\s(?=(¿|¡)[A-ZÃ-Ú])/$1. /gm;t' <<< "Cemré ¿Quién era?"