use strict;
my $str = 'Cemré ¿Quién era?';
my $regex = qr/([\wá-ú])\s(?=(¿|¡)[A-ZÃ-Ú])/mp;
my $subst = '$1. ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";