import Foundation
let pattern = #"([\wá-ú])\s(?=(¿|¡)[A-ZÃ-Ú])"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"Cemré ¿Quién era?"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1. "#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)