$re = '/([\wá-ú])\s(?=(¿|¡)[A-ZÃ-Ú])/m';
$str = 'Cemré ¿Quién era?';
$subst = "$1. ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;