using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d+)\s([\w ]+)\sat\s(\d+(?:\.\d+)?)";
string input = @"1 soccer ball at 10
2 Iphones 4s at 199.99
4 box of candy at 50";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}