import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d+)\\s([\\w ]+)\\sat\\s(\\d+(?:\\.\\d+)?)";
final String string = "1 soccer ball at 10\n"
+ "2 Iphones 4s at 199.99\n"
+ "4 box of candy at 50";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}