re = /(\d+)\s([\w ]+)\sat\s(\d+(?:\.\d+)?)/
str = '1 soccer ball at 10
2 Iphones 4s at 199.99
4 box of candy at 50'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end