import Foundation
let pattern = #"(\d+)\s([\w ]+)\sat\s(\d+(?:\.\d+)?)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
1 soccer ball at 10
2 Iphones 4s at 199.99
4 box of candy at 50
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)