const regex = /(\d+)\s([\w ]+)\sat\s(\d+(?:\.\d+)?)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d+)\\s([\\w ]+)\\sat\\s(\\d+(?:\\.\\d+)?)', 'g')
const str = `1 soccer ball at 10
2 Iphones 4s at 199.99
4 box of candy at 50`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}