import re
regex = re.compile(r"(\d+)\s([\w ]+)\sat\s(\d+(?:\.\d+)?)")
test_str = ("1 soccer ball at 10\n"
"2 Iphones 4s at 199.99\n"
"4 box of candy at 50")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")