$re = '/(\d+)\s([\w ]+)\sat\s(\d+(?:\.\d+)?)/';
$str = '1 soccer ball at 10
2 Iphones 4s at 199.99
4 box of candy at 50';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);