// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(\d+)\s([\w ]+)\sat\s(\d+(?:\.\d+)?)").unwrap();
let string = "1 soccer ball at 10
2 Iphones 4s at 199.99
4 box of candy at 50";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}