package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\d+)\s([\w ]+)\sat\s(\d+(?:\.\d+)?)`)
var str = `1 soccer ball at 10
2 Iphones 4s at 199.99
4 box of candy at 50`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}