#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\s+"(\.\/|\.\.\/|\/)?[^\/\n"]++(\/[^\/\n"]++)+"\s+"
Local $sString = "net use [devicename]: "/some path/to some/text/file.txt" [/user:"\domain\user"]" & @CRLF & _
"" & @CRLF & _
"net use [devicename]: "some path/to some/text/file.txt" [/user:"\domain\user"]" & @CRLF & _
"" & @CRLF & _
"net use [devicename]: "./some path/to some/text/file.txt" [/user:"\domain\user"]" & @CRLF & _
"" & @CRLF & _
"net use [devicename]: "../some path/to some/text/file.txt" [/user:"\domain\user"]" & @CRLF & _
"" & @CRLF & _
"net use [devicename]: "/some path/to some/text/file.txt [/user:"\domain\user"]" & @CRLF & _
"" & @CRLF & _
"net use [devicename]: /some_path/to_some/text/file.txt [/user:"\domain\user"]" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")