import Foundation
let pattern = #"\s+"(\.\/|\.\.\/|\/)?[^\/\n"]++(\/[^\/\n"]++)+"\s+"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
net use [devicename]: "/some path/to some/text/file.txt" [/user:"\domain\user"]
net use [devicename]: "some path/to some/text/file.txt" [/user:"\domain\user"]
net use [devicename]: "./some path/to some/text/file.txt" [/user:"\domain\user"]
net use [devicename]: "../some path/to some/text/file.txt" [/user:"\domain\user"]
net use [devicename]: "/some path/to some/text/file.txt [/user:"\domain\user"]
net use [devicename]: /some_path/to_some/text/file.txt [/user:"\domain\user"]
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)