using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s+""(\.\/|\.\.\/|\/)?[^\/\n""]++(\/[^\/\n""]++)+""\s+";
string input = @"net use [devicename]: ""/some path/to some/text/file.txt"" [/user:""\domain\user""]
net use [devicename]: ""some path/to some/text/file.txt"" [/user:""\domain\user""]
net use [devicename]: ""./some path/to some/text/file.txt"" [/user:""\domain\user""]
net use [devicename]: ""../some path/to some/text/file.txt"" [/user:""\domain\user""]
net use [devicename]: ""/some path/to some/text/file.txt [/user:""\domain\user""]
net use [devicename]: /some_path/to_some/text/file.txt [/user:""\domain\user""]
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}