// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)\s+"(\.\/|\.\.\/|\/)?[^\/\n"]++(\/[^\/\n"]++)+"\s+"#).unwrap();
let string = "net use [devicename]: \"/some path/to some/text/file.txt\" [/user:\"\\domain\\user\"]
net use [devicename]: \"some path/to some/text/file.txt\" [/user:\"\\domain\\user\"]
net use [devicename]: \"./some path/to some/text/file.txt\" [/user:\"\\domain\\user\"]
net use [devicename]: \"../some path/to some/text/file.txt\" [/user:\"\\domain\\user\"]
net use [devicename]: \"/some path/to some/text/file.txt [/user:\"\\domain\\user\"]
net use [devicename]: /some_path/to_some/text/file.txt [/user:\"\\domain\\user\"]
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}