package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\s+"(\.\/|\.\.\/|\/)?[^\/\n"]++(\/[^\/\n"]++)+"\s+`)
var str = `net use [devicename]: "/some path/to some/text/file.txt" [/user:"\domain\user"]
net use [devicename]: "some path/to some/text/file.txt" [/user:"\domain\user"]
net use [devicename]: "./some path/to some/text/file.txt" [/user:"\domain\user"]
net use [devicename]: "../some path/to some/text/file.txt" [/user:"\domain\user"]
net use [devicename]: "/some path/to some/text/file.txt [/user:"\domain\user"]
net use [devicename]: /some_path/to_some/text/file.txt [/user:"\domain\user"]
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}