re = /\s+"(\.\/|\.\.\/|\/)?[^\/\n"]++(\/[^\/\n"]++)+"\s+/m
str = 'net use [devicename]: "/some path/to some/text/file.txt" [/user:"\\domain\\user"]
net use [devicename]: "some path/to some/text/file.txt" [/user:"\\domain\\user"]
net use [devicename]: "./some path/to some/text/file.txt" [/user:"\\domain\\user"]
net use [devicename]: "../some path/to some/text/file.txt" [/user:"\\domain\\user"]
net use [devicename]: "/some path/to some/text/file.txt [/user:"\\domain\\user"]
net use [devicename]: /some_path/to_some/text/file.txt [/user:"\\domain\\user"]
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end