import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\s+\"(\\.\\/|\\.\\.\\/|\\/)?[^\\/\\n\"]++(\\/[^\\/\\n\"]++)+\"\\s+";
final String string = "net use [devicename]: \"/some path/to some/text/file.txt\" [/user:\"\\domain\\user\"]\n\n"
+ "net use [devicename]: \"some path/to some/text/file.txt\" [/user:\"\\domain\\user\"]\n\n"
+ "net use [devicename]: \"./some path/to some/text/file.txt\" [/user:\"\\domain\\user\"]\n\n"
+ "net use [devicename]: \"../some path/to some/text/file.txt\" [/user:\"\\domain\\user\"]\n\n"
+ "net use [devicename]: \"/some path/to some/text/file.txt [/user:\"\\domain\\user\"]\n\n"
+ "net use [devicename]: /some_path/to_some/text/file.txt [/user:\"\\domain\\user\"]\n\n\n\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}