const regex = /\s+"(\.\/|\.\.\/|\/)?[^\/\n"]++(\/[^\/\n"]++)+"\s+/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\s+"(\\.\\\/|\\.\\.\\\/|\\\/)?[^\\\/\\n"]++(\\\/[^\\\/\\n"]++)+"\\s+', 'mg')
const str = `net use [devicename]: "/some path/to some/text/file.txt" [/user:"\\domain\\user"]
net use [devicename]: "some path/to some/text/file.txt" [/user:"\\domain\\user"]
net use [devicename]: "./some path/to some/text/file.txt" [/user:"\\domain\\user"]
net use [devicename]: "../some path/to some/text/file.txt" [/user:"\\domain\\user"]
net use [devicename]: "/some path/to some/text/file.txt [/user:"\\domain\\user"]
net use [devicename]: /some_path/to_some/text/file.txt [/user:"\\domain\\user"]
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}