$re = '/\s+"(\.\/|\.\.\/|\/)?[^\/\n"]++(\/[^\/\n"]++)+"\s+/m';
$str = 'net use [devicename]: "/some path/to some/text/file.txt" [/user:"\\domain\\user"]
net use [devicename]: "some path/to some/text/file.txt" [/user:"\\domain\\user"]
net use [devicename]: "./some path/to some/text/file.txt" [/user:"\\domain\\user"]
net use [devicename]: "../some path/to some/text/file.txt" [/user:"\\domain\\user"]
net use [devicename]: "/some path/to some/text/file.txt [/user:"\\domain\\user"]
net use [devicename]: /some_path/to_some/text/file.txt [/user:"\\domain\\user"]
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);