#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = ".*?[\['](.*?\(Delete\).*?)[\]'].*"
Local $sString = "blah blah [manikv (Delete) 4916258] blah blah" & @CRLF & _
"blah blah 'morl20 (Delete) 180977' blah blah"
Local $sSubst = "\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)