const regex = /.*?[\['](.*?\(Delete\).*?)[\]'].*/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*?[\\[\'](.*?\\(Delete\\).*?)[\\]\'].*', 'g')
const str = `blah blah [manikv (Delete) 4916258] blah blah
blah blah 'morl20 (Delete) 180977' blah blah`;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);