package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`.*?[\['](.*?\(Delete\).*?)[\]'].*`)
var str = `blah blah [manikv (Delete) 4916258] blah blah
blah blah 'morl20 (Delete) 180977' blah blah`
var substitution = "\1"
fmt.Println(re.ReplaceAllString(str, substitution))
}