using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*?[\['](.*?\(Delete\).*?)[\]'].*";
string substitution = @"\1";
string input = @"blah blah [manikv (Delete) 4916258] blah blah
blah blah 'morl20 (Delete) 180977' blah blah";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}