re = /.*?[\['](.*?\(Delete\).*?)[\]'].*/
str = 'blah blah [manikv (Delete) 4916258] blah blah
blah blah \'morl20 (Delete) 180977\' blah blah'
subst = '\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result