import Foundation
let pattern = #".*?[\['](.*?\(Delete\).*?)[\]'].*"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
blah blah [manikv (Delete) 4916258] blah blah
blah blah 'morl20 (Delete) 180977' blah blah
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)