$re = '/.*?[\[\'](.*?\(Delete\).*?)[\]\'].*/';
$str = 'blah blah [manikv (Delete) 4916258] blah blah
blah blah \'morl20 (Delete) 180977\' blah blah';
$subst = "\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;