using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<form\s*[^>]*\s*href\s*=\s*((?:[^ ]|[\n\r])+)\s*[^>]*>\s*Text\s*<\/form>";
string input = @"<p>The Non-compliance Risk grid has been updated. </p>\r\n<p><a href=\""https://ca-cib.ca-mocca.com/site/cpl/EN/Pages/default.aspx\"">Available here.</a> </p>\r\n\r\n<form>\r\n First name: \r\n <input type=\""text\"" name=\""first_name\"" value=\""\"" maxlength=\""100\"">\r\n <br>\r\n \r\n Last name: \r\n <input type=\""text\"" name=\""last_name\"" value=\""\"" maxlength=\""100\"">\r\n <input type=\""submit\"" value=\""Submit\"">\r\n </form>\r\n\r\nTesting";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}