// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"<form\s*[^>]*\s*href\s*=\s*((?:[^ ]|[\n\r])+)\s*[^>]*>\s*Text\s*<\/form>").unwrap();
let string = "<p>The Non-compliance Risk grid has been updated. </p>\\r\\n<p><a href=\\\"https://ca-cib.ca-mocca.com/site/cpl/EN/Pages/default.aspx\\\">Available here.</a> </p>\\r\\n\\r\\n<form>\\r\\n First name: \\r\\n <input type=\\\"text\\\" name=\\\"first_name\\\" value=\\\"\\\" maxlength=\\\"100\\\">\\r\\n <br>\\r\\n \\r\\n Last name: \\r\\n <input type=\\\"text\\\" name=\\\"last_name\\\" value=\\\"\\\" maxlength=\\\"100\\\">\\r\\n <input type=\\\"submit\\\" value=\\\"Submit\\\">\\r\\n </form>\\r\\n\\r\\nTesting";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}