use strict;
my $str = '<p>The Non-compliance Risk grid has been updated. </p>\\r\\n<p><a href=\\"https://ca-cib.ca-mocca.com/site/cpl/EN/Pages/default.aspx\\">Available here.</a> </p>\\r\\n\\r\\n<form>\\r\\n First name: \\r\\n <input type=\\"text\\" name=\\"first_name\\" value=\\"\\" maxlength=\\"100\\">\\r\\n <br>\\r\\n \\r\\n Last name: \\r\\n <input type=\\"text\\" name=\\"last_name\\" value=\\"\\" maxlength=\\"100\\">\\r\\n <input type=\\"submit\\" value=\\"Submit\\">\\r\\n </form>\\r\\n\\r\\nTesting';
my $regex = qr/<form\s*[^>]*\s*href\s*=\s*((?:[^ ]|[\n\r])+)\s*[^>]*>\s*Text\s*<\/form>/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}