const regex = new RegExp('<form\\s*[^>]*\\s*href\\s*=\\s*((?:[^ ]|[\\n\\r])+)\\s*[^>]*>\\s*Text\\s*<\\/form>', 'g')
const str = `<p>The Non-compliance Risk grid has been updated. </p>\\r\\n<p><a href=\\"https://ca-cib.ca-mocca.com/site/cpl/EN/Pages/default.aspx\\">Available here.</a> </p>\\r\\n\\r\\n<form>\\r\\n First name: \\r\\n <input type=\\"text\\" name=\\"first_name\\" value=\\"\\" maxlength=\\"100\\">\\r\\n <br>\\r\\n \\r\\n Last name: \\r\\n <input type=\\"text\\" name=\\"last_name\\" value=\\"\\" maxlength=\\"100\\">\\r\\n <input type=\\"submit\\" value=\\"Submit\\">\\r\\n </form>\\r\\n\\r\\nTesting`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}