import Foundation
let pattern = #"<form\s*[^>]*\s*href\s*=\s*((?:[^ ]|[\n\r])+)\s*[^>]*>\s*Text\s*<\/form>"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"<p>The Non-compliance Risk grid has been updated. </p>\r\n<p><a href=\"https://ca-cib.ca-mocca.com/site/cpl/EN/Pages/default.aspx\">Available here.</a> </p>\r\n\r\n<form>\r\n First name: \r\n <input type=\"text\" name=\"first_name\" value=\"\" maxlength=\"100\">\r\n <br>\r\n \r\n Last name: \r\n <input type=\"text\" name=\"last_name\" value=\"\" maxlength=\"100\">\r\n <input type=\"submit\" value=\"Submit\">\r\n </form>\r\n\r\nTesting"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)