$re = '/<form\s*[^>]*\s*href\s*=\s*((?:[^ ]|[\n\r])+)\s*[^>]*>\s*Text\s*<\/form>/';
$str = '<p>The Non-compliance Risk grid has been updated. </p>\\r\\n<p><a href=\\"https://ca-cib.ca-mocca.com/site/cpl/EN/Pages/default.aspx\\">Available here.</a> </p>\\r\\n\\r\\n<form>\\r\\n First name: \\r\\n <input type=\\"text\\" name=\\"first_name\\" value=\\"\\" maxlength=\\"100\\">\\r\\n <br>\\r\\n \\r\\n Last name: \\r\\n <input type=\\"text\\" name=\\"last_name\\" value=\\"\\" maxlength=\\"100\\">\\r\\n <input type=\\"submit\\" value=\\"Submit\\">\\r\\n </form>\\r\\n\\r\\nTesting';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);