import re
regex = re.compile(r"<form\s*[^>]*\s*href\s*=\s*((?:[^ ]|[\n\r])+)\s*[^>]*>\s*Text\s*<\/form>")
test_str = "<p>The Non-compliance Risk grid has been updated. </p>\\r\\n<p><a href=\\\"https://ca-cib.ca-mocca.com/site/cpl/EN/Pages/default.aspx\\\">Available here.</a> </p>\\r\\n\\r\\n<form>\\r\\n First name: \\r\\n <input type=\\\"text\\\" name=\\\"first_name\\\" value=\\\"\\\" maxlength=\\\"100\\\">\\r\\n <br>\\r\\n \\r\\n Last name: \\r\\n <input type=\\\"text\\\" name=\\\"last_name\\\" value=\\\"\\\" maxlength=\\\"100\\\">\\r\\n <input type=\\\"submit\\\" value=\\\"Submit\\\">\\r\\n </form>\\r\\n\\r\\nTesting"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")