use strict;
my $str = 'asd😂 ads😂ads
asd🖑😂😂😂😂asd
dasd😂asd';
my $regex = qr/[\u0000-\uFFFF]/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";