# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\s*)PlayerPoints1\[(.*?)\](\s*)/$2/gm;t' <<< "
PlayerPoints1[400]
"