const regex = /(\s*)PlayerPoints1\[(.*?)\](\s*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\s*)PlayerPoints1\\[(.*?)\\](\\s*)', 'gm')
const str = `
PlayerPoints1[400]
`;
const subst = `$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);