use strict;
my $str = '
PlayerPoints1[400]
';
my $regex = qr/(\s*)PlayerPoints1\[(.*?)\](\s*)/mp;
my $subst = '$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";