re = /(\s*)PlayerPoints1\[(.*?)\](\s*)/m
str = '
PlayerPoints1[400]
'
subst = '$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result