#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mx)(?i)" & @CRLF & _
"(\[)?" & @CRLF & _
"(?(1)|(\*)?" & @CRLF & _
"(?(2)|(\{)?" & @CRLF & _
"(?(3)|(\()?" & @CRLF & _
")))" & @CRLF & _
"(?:secure|encrypt)" & @CRLF & _
"(?(1)]" & @CRLF & _
"|(?(2)\*" & @CRLF & _
"|(?(3)}" & @CRLF & _
"|(?(4)\)" & @CRLF & _
"|(*FAIL)" & @CRLF & _
"))))"
Local $sString = "Don't match:" & @CRLF & _
"{secure]" & @CRLF & _
"{spatula}" & @CRLF & _
"secure[(secure])" & @CRLF & _
"~secure~" & @CRLF & _
"" & @CRLF & _
"Match:" & @CRLF & _
"[secure]" & @CRLF & _
"*ENCRYPT*" & @CRLF & _
"{EnCrYpT}" & @CRLF & _
"(sEcUrE)" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"Secure or Encrypt within *,{, [ or ("
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")