package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mx)(?i)
(\[)?
(?(1)|(\*)?
(?(2)|(\{)?
(?(3)|(\()?
)))
(?:secure|encrypt)
(?(1)]
|(?(2)\*
|(?(3)}
|(?(4)\)
|(*FAIL)
))))`)
var str = `Don't match:
{secure]
{spatula}
secure[(secure])
~secure~
Match:
[secure]
*ENCRYPT*
{EnCrYpT}
(sEcUrE)
Secure or Encrypt within *,{, [ or (`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}