import re
regex = re.compile(r"""
(?i)
(\[)?
(?(1)|(\*)?
(?(2)|(\{)?
(?(3)|(\()?
)))
(?:secure|encrypt)
(?(1)]
|(?(2)\*
|(?(3)}
|(?(4)\)
|(*FAIL)
))))
""", flags=re.MULTILINE | re.VERBOSE)
test_str = ("Don't match:\n"
"{secure]\n"
"{spatula}\n"
"secure[(secure])\n"
"~secure~\n\n"
"Match:\n"
"[secure]\n"
"*ENCRYPT*\n"
"{EnCrYpT}\n"
"(sEcUrE)\n\n\n\n\n"
"Secure or Encrypt within *,{, [ or (")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")